English
« Back to projectatomic.io
Ask Your Question
0

Cockpit limited rights

asked 2015-01-21 18:14:23 +0000

repta gravatar image

Hi there,

i'm using the Fedora image and set a password via user-data. But when i open cockpit, a htaccess prompt appears where the creds (user fedora + pwd) arent accepted. After this, when i skip the prompt with cancel, the "regular" cockpit login shows up. There the login works, but with limited rights, ie. im not able to display the container section. Where did i miss the option to enable full access to cockpit? I think, I didnt set the root pw not at all?

Thanks in advance!

edit retag flag offensive close merge delete

4 answers

Sort by » oldest newest most voted
0

answered 2018-01-22 09:42:47 +0000

caia gravatar image

It is the first time I am hearing about the cockpit. I don’t know the answer to this question. What is this question all about? It will be good if somebody who knows this term reply and provides the essential details so that all know about it. best internet providers

edit flag offensive delete link more
0

answered 2017-12-27 14:11:52 +0000

Logan gravatar image

This is a post which I am came across when a took a break from my essay writer. Frankly speaking I have no idea but i did read your question with great interest. i hope you get the answer soon.

edit flag offensive delete link more
0

answered 2017-12-05 11:58:58 +0000

hellenjos gravatar image

I didn’t know the answer to this question. It would be better if you share the question to some other site related to this topic. so that people who know the answer will tell you the correct answer. So share it on some other sites. garage doors in my area Irvine

edit flag offensive delete link more
0

answered 2015-01-21 22:08:28 +0000

I believe cockpit roles are based on system groups, so right now you'd want to add an entry in /etc/group for the fedora user.

But, /etc/group may not have the wheel group listed in an Atomic host as they get picked up from /usr/lib/group. So check /usr/lib/group to see what the entry should read, add that to /etc/group with the fedora user, and then try logging into cockpit.

At least, that's what I did to get things working on a local set of Atomic hosts.

[fedora@atomic-host-001 ~]$ cat /etc/group
root:x:0:
fedora:x:1000:
wheel:x:10:fedora

There may be a different way of enabling this, but I wasn't able to find one yet.

edit flag offensive delete link more

Comments

I experienced a similar problem. I can login with fedora credentials, but the user haven't the permissions to admin / manage docker.

pwFoo ( 2015-02-03 10:53:39 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Stats

Asked: 2015-01-21 18:14:23 +0000

Seen: 616 times

Last updated: 12 hours ago