English
« Back to projectatomic.io
Ask Your Question
0

How do you pass multiple switches in KUBELET_ARGS?

asked 2015-03-16 14:46:39 +0000

Paul Knox-Kennedy gravatar image

I would like to set both clusterdns and clusterdomain in KUBELET_ARGS, e.g.

KUBELET_ARGS="--cluster_dns=10.254.0.10 --cluster_domain=kubernetes.local"

but the expansion in the systemd unit file causes kubelet to fail with

invalid IP address: '10.254.0.10 --cluster_domain=kubernetes.local'

i.e. the kubelet is seeing everything after cluster_dns= as a single parameter. I have worked around it by overriding the unit file, but would like to know the "correct" way to do this.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-03-16 15:37:31 +0000

I ran into this setting up cluster_dns as well. Put a whitespace before the first argument and it will work. e.g.:

KUBELET_ARGS=" --cluster_dns=10.254.0.10 --cluster_domain=kubernetes.local"

Haven't found a reason why that option is eating whitespace to file a bug report yet, but the work around seems to function consistently.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2015-03-16 14:46:39 +0000

Seen: 1,907 times

Last updated: Mar 16 '15