English
« Back to projectatomic.io
Ask Your Question
0

cannot login trough console with centos image

asked 2015-05-08 07:25:53 +0000

rolfiee gravatar image

Hi there,

i cannot login with into the console.

I'm using the following user-data file

cloud-config

user: atomic password: atomic chpasswd: { expire: False } sshpwauth: False sshauthorized_keys: - ssh-rsa snip chpasswd: list: | root:password cloud-user:atomic expire: False

The meta-data is as follows: instance-id: Atomic01 local-hostname: atomic-host-001

And build the iso with the following command:

[root@lap Downloads]# genisoimage -output atomic01-cidata.iso -volid cidata -joliet -rock user-data meta-data I: -input-charset not specified, using utf-8 (detected in locale settings) Total translation table size: 0 Total rockridge attributes bytes: 331 Total directory bytes: 0 Path table size(bytes): 10 Max brk space used 0 183 extents written (0 MB)

The I mount the iso file in virtualbox but cant login. But i'm also seeing localhost login:

localhost should be atomic-host-001 because that is in the meta-data file.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-05-26 16:12:42 +0000

You've got multiple chpasswd: entries that need to be consolidated. You can move the expiration to the end of the list block like this:

chpasswd:
  list: |
    root:password
    cloud-user:atomic
  expire: False

Whitespace is critical for that style of block to avoid passwords with trailing or leading spaces.

It could take a while for cloud-init to complete, so you may see the first login as localhost. Press enter a few times and see if the hostname updates. Then you can try to log in.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Stats

Asked: 2015-05-08 07:25:53 +0000

Seen: 1,259 times

Last updated: May 26 '15