English
« Back to projectatomic.io
Ask Your Question
0

Cockpit issue (systemctl enable cockpit.socket)

asked 2015-05-15 13:47:57 +0000

Shambola gravatar image

updated 2015-05-15 13:48:27 +0000

Hi, I'm trying bare-metal VM based on Fedora 22 Beta but I have an issue with Cockpit:

*-bash-4.3# systemctl enable cockpit.socket

Failed to execute operation: No such file or directory*

What am I doing wrong?

Thanks!

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
1

answered 2015-05-28 20:57:23 +0000

We found the answer! The cockpit team moved how cockpit gets run under Atomic to a privileged container.

The short answer is as the 'fedora' user:

sudo atomic run cockpit/ws

Once you've logged in with the fedora user, you can add other Atomic hosts that can be reached from that initial host. You'll need to have set up password authentication for the fedora user.

The longer answer can be found in the project GitHub wiki https://github.com/cockpit-project/co...

edit flag offensive delete link more

Comments

GOOOD! It works! Thanks!!

Shambola ( 2015-05-29 15:24:59 +0000 )edit
1

answered 2015-05-26 09:38:03 +0000

Shambola gravatar image

mhh, there isn't!

Reading http://www.projectatomic.io/download/ instruction I assumed that Cockpit was included in (every) installer. Maybe Fedora 22 don't contain it yet?

Btw, thanks

edit flag offensive delete link more
0

answered 2015-05-24 16:14:01 +0000

msx gravatar image

Did you check that /usr/lib/systemd/system/cockpit.socket is there?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2015-05-15 13:47:57 +0000

Seen: 629 times

Last updated: May 28 '15