English
« Back to projectatomic.io
Ask Your Question
0

unable to compose tree on fedora 21 : rpm-ostree compose tree --proxy=http://127.0.0.1:8123 --repo=/srv/rpm-ostree/repo fedora-atomic-docker-host.json

asked 2015-05-29 06:55:51 +0000

sujit gravatar image

yum> run Waiting for yum...

One of the configured repositories failed (Fedora 21 - x86_64), and yum doesn't have enough cached data to continue. At this point the only safe thing yum can do is fail. There are a few ways to work "fix" this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Disable the repository, so yum won't use it by default. Yum will then
    just ignore the repository until you permanently enable it again or use
    --enablerepo for temporary usage:

        yum-config-manager --disable fedora-21

 4. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=fedora-21.skip_if_unavailable=true

Cannot retrieve metalink for repository: fedora-21/x86_64. Please verify its path and try again

error: Child process exited with code 1

edit retag flag offensive close merge delete

Comments

1

Are you running in a container or in a VM? I ran into issues with yum and network issues in a container that disappeared when I used a VM. So, I just use a VM for local compose tree building.

nzwulfin ( 2015-05-29 12:36:26 +0000 )edit

Just checking in - did you get this figured out?

jzb ( 2015-06-29 18:28:19 +0000 )edit
1

ya got solution : following steps worked for me.. vi /etc/yum.repos.d/fedora.repo then, at the [Fedora] section, uncomment baseurl and set the value to For i386 arch, the value must be: baseurl=http://ftp.riken.jp/Linux/fedora/releases/21/Everything/i386/os/ for x86-64 systems, the value must

sujit ( 2015-06-29 19:56:35 +0000 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-06-29 19:57:24 +0000

sujit gravatar image

vi /etc/yum.repos.d/fedora.repo

then, at the [Fedora] section, uncomment baseurl and set the value to

For i386 arch, the value must be: baseurl=http://ftp.riken.jp/Linux/fedora/releases/21/Everything/i386/os/

for x86-64 systems, the value must be: baseurl=http://ftp.riken.jp/Linux/fedora/releases/21/Everything/x86_64/os/

after this, comment metalink :

metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch

then, save the file and use yum again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2015-05-29 06:55:51 +0000

Seen: 6,789 times

Last updated: Jun 29 '15