English
« Back to projectatomic.io
Ask Your Question
1

Kubernetes versioning

asked 2016-01-23 15:32:56 +0000

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi,

I was wondering where I can find the which versions of Kubernetes are supported by which Atomic host versions. I am using the Centos version, but noticed that it uses an old version of Kubernetes (V1.0.3) even after atomic host upgrade.

Thanks, Andrej

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2016-03-11 15:14:32 +0000

dohnto gravatar image

Similar situation in Fedora Atomic (Version: 23.81) and Kubernetes in version 1.0.6. How often can we except upstream upgrades? I cannot find any information on that topic, thanks in advance!

edit flag offensive delete link more
0

answered 2016-02-16 22:22:18 +0000

jasonbrooks gravatar image

Version 7.2.2 of the RHEL Atomic Host just updated to kubernetes 1.2.0-0.6.alpha1.git8632732.el7 (interestingly, because k8s 1.2 isn't out yet), so centos atomic will soon have that pkg version.

edit flag offensive delete link more
0

answered 2016-02-11 20:02:34 +0000

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

The last atomic host upgrade did not upgrade Kubernetes to 1.1.+ and now we are stil stuck with an ancient 1.0.3 version!

How long will this take?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Stats

Asked: 2016-01-23 15:32:56 +0000

Seen: 663 times

Last updated: Mar 11 '16