English
« Back to projectatomic.io
Ask Your Question
0

login incorrect on fedora

asked 2015-07-30 04:05:48 +0000

parann0yed gravatar image

I've looked at several docs regarding creating an init.iso. These three in particular:

http://www.projectatomic.io/blog/2014...

http://www.projectatomic.io/docs/quic...

https://access.redhat.com/articles/rh...

My meta-data and user-data:

meta-data instance-id: id-local06 local-hostname: test-01

user-data password:mypassword ssh_pwauth: True chpasswd: { expire: False }

sshauthorizedkeys: - ssh-rsa AA... bob@myhostname

Then I generate my init.iso:

genisoimage -output init.iso -volid cidata -joliet -rock user-data meta-data

I read that the fedora 22 image I'm using is expecting a username of "fedora". I try that and my password. I got "Login incorrect".

I try to ssh to the kvm and it gives "permission denied".

Does any one see anything I am doing wrong? The public key I'm using is from my kvm host. Thank you.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-07-30 04:38:20 +0000

parann0yed gravatar image

OK, I went to edit my user-data file and there it was (in part) at the top. My typo of #clould-config vs #cloud-config. I also forgot to increment the instance-id after that change so didn't think that fixed it. Once updated it worked! A question though about selinux. It was on when I first started creating the iso. I set to permissive. If left on I wonder if that would cause issues. I guess more testing will reveal that.

I'm psyched to continue this. Thanks for any feedback.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2015-07-30 04:05:48 +0000

Seen: 2,128 times

Last updated: Jul 30 '15