English
« Back to projectatomic.io
Ask Your Question
0

How do I set up a static networking configuration?

asked 2016-02-06 17:01:52 +0000

lucodealethea gravatar image

According to How do I set up a static networking configuration? in https://access.redhat.com/documentati...

I tried in meta-data file the following: instance-id:atomic-master local-hostname: atomic-master.xxx.com network-interfaces: | iface ens3 inet static address 192.168.0.214 network 192.168.0.0 netmask 255.255.255.0 broadcast 192.168.0.255 gateway 192.168.0.1 bootcmd: - ifdown ens3 - ifup ens3

without success, dhcp at boot is used and ip static setup is in vain...

sudo nmcli connection show

What would the steps or is it not possible to arrange a set of atomic hosts with static ip ? Also, how to get a better sense of what of ostree cannot be overridden by cloud-init set-up ?

thx in advance

edit retag flag offensive close merge delete

Comments

Which version / distro of Atomic are you running?

nzwulfin ( 2016-02-10 16:19:22 +0000 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-02-10 19:41:22 +0000

There really isn't a connection between ostree and cloud-initfor networking. The problem with cloud-init and static networking is an upstream bug that hasn't been resolved yet. https://bugs.launchpad.net/cloud-init...

What's worked for me has been moving the restart of the network interface to user-data from meta-data. Also, that example is missing an auto eth0 line in meta-data which I've found is needed.

In my working meta-data:

instance-id: Atomic001
local-hostname: atomic-001
network-interfaces: |
  auto ens3
  iface ens3 inet static
    address 192.168.122.11
    network 192.168.122.0
    netmask 255.255.255.0
    broadcast 192.168.122.255
    gateway 192.168.122.1

And in user-data:

runcmd:
  - ifdown ens3
  - ifup ens3
edit flag offensive delete link more

Comments

Looks good to me also, thanks a lot !!

lucodealethea ( 2016-02-10 20:19:23 +0000 )edit
0

answered 2016-02-10 19:03:51 +0000

lucodealethea gravatar image

sudo atomic --version 1.8

I could make static ip working by tweaking in this sequence: 0. meta-data for init_atomic.iso:

instance-id: atomic-03 local-hostname: atomic-03.xxx.com network-interfaces: | iface ens3 inet static address 192.168.0.2 network 192.168.0.0 netmask 255.255.255.0 broadcast 192.168.0.255 gateway 192.168.0.1

  1. disconnect from inet
  2. create in virt-manager a virtual network/bridge virbr0 static without dhcp ipv4 range
  3. boot atomic vm
  4. login and note that sudo nmcli con show ens3 has no interface
  5. shutdown atomic vm
  6. delete in virt-manager the static ip virtual network virbr0
  7. recreate in virt-manager virbr0 virtual network/bridge as dhcp WITH dhcp range 192.168.0.1-254
  8. restart atomic vm
  9. ifconfig shows the ens3 interface on 192.168.0.2

Conclusion: setting a master and four atomic hosts with DHCP is easier that trying the static assignment, but if the dnsmask sequence is broken like atomic master ip address is in between other atomic/non-atomic hosts ip addresses instead of being the first in the line, is a bit inconvenient. It is just that I couldn't find how to reset this sequencing on the physical host libvirt/dnsmask configuration. Any idea or help is welcome.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2016-02-06 17:01:52 +0000

Seen: 830 times

Last updated: Feb 10 '16