How to make kube-apiserver start as pod ?

asked 2016-02-17 16:34:41 +0000

GregoryM gravatar image

Hello Atomic Hosts experts. I try to start kubernetes kube-apiserver as Pod using bellow configuration over AWS cloud(Francfurt)

/etc/kubernetes/manifests/kube-apiserver.yaml is

apiVersion: v1 kind: Pod metadata: name: kube-apiserver spec: hostNetwork: true containers: - name: kube-apiserver image: gcr.io/google_containers/kube-apiserver:9680e782e08a1a1c94c656190011bd02 command: - /bin/sh - -c - /usr/local/bin/kube-apiserver --insecure-bind-address=0.0.0.0 --etcd-servers=http://10.10.50.238:4001,http://10.10.50.238:2379 --cloud-provider='' --admission-control=NamespaceLifecycle,LimitRanger,SecurityContextDeny,ServiceAccount,ResourceQuota --service-cluster-ip-range=10.1.110.0/24 --client-ca-file=/srv/kubernetes/ca.crt --cluster-name=e2e-test-bburns --tls-cert-file=/srv/kubernetes/server.crt --tls-private-key-file=/srv/kubernetes/server.key --secure-port=443 --insecure-port=8080 --v=4 --allow-privileged=true ports: - containerPort: 443 hostPort: 443 name: https - containerPort: 7080 hostPort: 7080 name: http - containerPort: 8080 hostPort: 8080 name: local volumeMounts: - mountPath: /srv/kubernetes name: srvkube readOnly: true - mountPath: /var/log/kube-apiserver.log name: logfile - mountPath: /etc/ssl name: etcssl readOnly: true - mountPath: /var/usr/share/ssl name: usrsharessl readOnly: true - mountPath: /var/ssl name: varssl readOnly: true - mountPath: /var/usr/ssl name: usrssl readOnly: true - mountPath: /var/usr/lib/ssl name: usrlibssl readOnly: true - mountPath: /var/usr/local/openssl name: usrlocalopenssl readOnly: true - mountPath: /etc/openssl name: etcopenssl readOnly: true - mountPath: /etc/pki/tls name: etcpkitls readOnly: true volumes: - hostPath: path: /srv/kubernetes name: srvkube - hostPath: - mountPath: /etc/openssl name: etcopenssl readOnly: true - mountPath: /etc/pki/tls name: etcpkitls readOnly: true volumes: - hostPath: path: /srv/kubernetes name: srvkube - hostPath: path: /var/log/kube-apiserver.log name: logfile - hostPath: path: /etc/ssl name: etcssl - hostPath: path: /var/usr/share/ssl name: usrsharessl - hostPath: path: /var/ssl name: varssl - hostPath: path: /var/usr/ssl name: usrssl - hostPath: path: /var/usr/lib/ssl name: usrlibssl - hostPath: path: /var/usr/local/openssl name: usrlocalopenssl - hostPath: path: /etc/openssl name: etcopenssl - hostPath: path: /etc/pki/tls name: etcpkitls

I succeeded to run kube-apiserver as docker but when I start kubelet I found in kubelet journal Errors as following:

What am I do wrong? Please advise.

Starting Kubernetes Kubelet Server... Started Kubernetes Kubelet Server. server.go:273] Using root directory: /var/lib/kubelet manager.go:127] cAdvisor running in container: "/system.slice/kubelet.service" fs.go:93] Filesystem partitions: map[/dev/mapper/atomicos-root:{mountpoint:/sysroot major:253 minor:0} /dev/xvda1:{mountpoint:/boot major:202 minor:1}] manager.go:156] Machine: {NumCores:2 CpuFrequency:2400094 MemoryCapacity:7934193664 MachineID:87ca2356a5f649d6ba12acad28e4fd80 SystemUUID:EC29...apper/atomicos-ro manager.go:163] Version: {KernelVersion:3.10.0-229.20.1.el7.x8664 ContainerOsVersion:CentOS Linux 7 (Core) DockerVersion:1.8.2 CadvisorVersion:0.15.1} plugins.go:69] No cloud provider specified. server.go:292] Successfully initialized cloud provider: "" from the config file: "" server.go:413] Using self-signed cert (/var/run/kubernetes/kubelet.crt, /var/run/kubernetes/kubelet.key) docker.go:295] Connecting to docker on unix:///var/run/docker.sock server.go:608] Sending events to api server. server.go:663] Adding manifest file: /etc/kubernetes/manifests file.go:47] Watching path "/etc/kubernetes/manifests" server.go:673] Watching apiserver file.go:135] Reading ... (more)

edit retag flag offensive close merge delete