English
« Back to projectatomic.io
Ask Your Question
0

Update docker engine?

asked 2016-03-02 15:00:16 +0000

Yzord gravatar image

I have installed CentOS Atomic (latest) and installed Compose on it (don't know if that was wise though). But when i want to run compose i get the following message:

ERROR: The engine version is lesser than the minimum required by compose. Your current project requires a Docker Engine of version 1.9.0 or superior.

So, my thoughts are, update the engine...but how do i do that? Rpm-ostree does not give me any option for it.

Docker version 1.8.2-el7.centos, build a01dc02/1.8.2 Docker-compose version 1.6.2, build 4d72027

Or is it not possible (yet) to update it and i have to use CentOS7 minimal installation for it?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-03-03 14:05:45 +0000

Individual RPMs can't be updated independently, in order to provide a newer version of Docker to your Atomic hosts you'd need to build a local compose tree. You can see an example of how to create and maintain a local tree here:

https://github.com/jasonbrooks/byo-at...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Stats

Asked: 2016-03-02 15:00:16 +0000

Seen: 1,590 times

Last updated: Mar 03 '16