English
« Back to projectatomic.io
Ask Your Question
1

rpm-ostree upgrade error

asked 2016-03-27 08:45:10 +0000

LouDog gravatar image

updated 2016-03-30 21:14:03 +0000

vjoshi gravatar image

Hello,

I am new to Atomic Host and I am trying to update my OS. I have build the image from an .iso and I then ran the following command.

sudo rpm-ostree upgrade

I was then given the following error. :error: fsetxattr: invalid argument

After looking online I found a solution which states the following for this error which appears to be a bug. I ran the following command.

runcon -r system_r -t install_t atomic upgrade But I then received another error which stated the following.

runcon: atomic: Permission denied.

Does anyone have any thoughts on how I can update my new Atomic Host image? Thank you, kindly.

-Louis

I ran sudo rpm-ostree upgrade, which gave me error: fsetxattr: Invalid argument . I followed the instructions given on the accepted answer at http://ask.projectatomic.io/en/questi... , but running runcon -r system_r -t install_t atomic host upgrade gives me runcon: atomic: Permission denied. I made sure to include host, but it is still not working.

edit retag flag offensive close merge delete

3 answers

Sort by » oldest newest most voted
1

answered 2016-03-29 18:57:38 +0000

walters gravatar image

See https://bugzilla.redhat.com/show_bug....

The current simplest workaround is to setenforce 0, there is a more complex workaround that doesn't involve temporary global permissive mode.

edit flag offensive delete link more

Comments

This is the simplest method that works.

rjdkolb ( 2017-04-03 05:06:51 +0000 )edit
0

answered 2017-11-01 01:57:01 +0000

clothing ny industries.

Not only the food craft buildin clothing g, the hotel - restaurant area, and care providers shoes have it difficult.

You look at the vacancies can be found also professions such as electronics t women echnicians, retail merchants, auto mechanic, and many more.

Even though the official start of the down jackets training is long gone, yet it is not too late to get into the training.

The careers counsellors women down jackets for the 63 currently unserved applicants to mediation promotion runs until December.

Who is still women clothes looking for an apprenticeship, should log in as quickly as possible to the consultancy, the offer i ennbuy.com s more varied.

The employment agency aims to bring as many teenagers and young adults in training.

edit flag offensive delete link more
0

answered 2016-03-27 10:04:30 +0000

LouDog gravatar image

updated 2016-03-27 10:10:26 +0000

Disregard,

The information in the following post is wrong.

link:http://www.projectatomic.io/blog/2015/04/atomic-news-fedora-22-beta-centos-update-glitch/

The actual command is runcon -r system_r -t install_t atomic host upgrade

Notice the command host needs to be in the command. Thank you Kodiak Firesmith.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Stats

Asked: 2016-03-27 08:45:10 +0000

Seen: 428 times

Last updated: Nov 01