English
« Back to projectatomic.io
Ask Your Question
0

problems running Ubuntu container?

asked 2015-08-28 03:51:28 +0000

jharrop gravatar image

updated 2015-08-28 03:55:57 +0000

Briefly after using the container for a short while, issuing the ls command results in

bash: /bin/ls: Input/output error

then when I exited the container, I got:

FATA[0000] Error response from daemon: Error running DeviceCreate (createSnapDevice) dm_task_run failed

I'm running Fedora Atomic 22 on AWS.

My Dockerfile is:

FROM java:openjdk-8-jdk

ENV MAVEN_VERSION 3.3.3

RUN curl -fsSL http://archive.apache.org/dist/maven/maven-3/$MAVEN_VERSION/binaries/apache-maven-$MAVEN_VERSION-bin.tar.gz | tar xzf - -C /usr/share \
  && mv /usr/share/apache-maven-$MAVEN_VERSION /usr/share/maven \
  && ln -s /usr/share/maven/bin/mvn /usr/bin/mvn

EXPOSE 8080

ENV MAVEN_HOME /usr/share/maven

After build/run, in the container I issued:

git clone  https://github.com/plutext/sling --branch trunk --single-branch
Cloning into 'sling'...
remote: Counting objects: 223683, done.
remote: Compressing objects: 100% (204/204), done.
remote: Total 223683 (delta 81), reused 6 (delta 6), pack-reused 223399
Receiving objects: 100% (223683/223683), 57.54 MiB | 5.37 MiB/s, done.
Resolving deltas: 100% (92716/92716), done.
Checking connectivity... done.

then I issued a few ls and cd commands, then ls stopped working, but cd still works.

java:openjdk-8-jdk is based on dockerfile/ubuntu

Hence my question: any idea what might be wrong running an Ubuntu container inside Fedora?

And now, trying to build/run my maven dockerfile again, I get:

sudo docker build maven
Sending build context to Docker daemon 2.048 kB
Sending build context to Docker daemon
Step 0 : FROM java:openjdk-8-jdk
 ---> 2f5a61e35ea4
Step 1 : ENV MAVEN_VERSION 3.3.3
INFO[0000] Error running DeviceCreate (createSnapDevice) dm_task_run failed

Thoughts? thanks .. Jason

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-08-28 08:00:17 +0000

jharrop gravatar image

Maybe the git clone I/O caused the physical hardware at AWS to die; in any case docker in the host no longer works properly. I'll have to discard that host and create a new AMI.

https://forums.aws.amazon.com/thread....

edit flag offensive delete link more

Comments

If you try this again and run into the same issues, can you file a ticket with the Fedora Cloud working group or send us an email at cloud@lists.fedoraproject.org? Thanks!

jzb ( 2015-08-28 15:07:41 +0000 )edit

That error also could be a symptom of disk space issues. The git clone, the size of the container, and general use could wind up using up the disk created when you launched the instance.

nzwulfin ( 2015-08-31 16:08:51 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2015-08-28 03:51:28 +0000

Seen: 974 times

Last updated: Aug 28 '15